Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#49 closed defect (wontfix)

Drop 2.3 support, make 2.5 for Python 2.5 +

Reported by: ssteiner Owned by: schwa
Priority: minor Milestone: 2.5
Component: Library Version: 2.4.2
Keywords: Cc:

Description

At this point, 2.3 is long gone so claiming 2.3 support, but having no tests (or systems with 2.3 to run them on!) seems counter-productive.

Maybe flag 2.4.2 as "last version compatible with 2.3" and bump ftputil 2.5 up to (gasp) Python 2.5.

2.7 is just around the corner and leaving out all the improvements of later versions of Python (and not testing older version compatibility) just seems cruel to anyone stuck on ancient versions of Python (as if that weren't cruel enough).

Change History (2)

comment:1 Changed 9 years ago by schwa

Resolution: wontfix
Status: newclosed

The topic was discussed on the mailing list and the best approach seems to be to increase the minimum Python version for ftputil but to stick to Python 2.4 for now.

At some point, we'll move forward and increase the minimum requirement to Python 2.5. When you think the time has come, please reopen the ticket. :-)

comment:2 Changed 9 years ago by schwa

Priority: majorminor

I've set the priority to "minor" because this issue only regards people working on ftputil, not just using it. The library can be used with any Python version 2.x where x >= 4.

Note: See TracTickets for help on using tickets.