Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#34 closed enhancement (invalid)

New parser needed for some unix variants

Reported by: ftputiluser Owned by: schwa
Priority: major Milestone: never
Component: Library Version:
Keywords: parser, Unix Cc:

Description (last modified by schwa)

The ftputil parser works fine with windows and standard unix directory format however there are some common unix variants ftputil doesn't understand such as ftp.sunfreeware.com .

tp> ls
 227 Entering Passive Mode (66,193,208,66,41,119)
 150 Opening ASCII mode data connection for /bin/ls.
 total 10
 lrwxrwxrwx 1 staff 7 Aug 13 2003 bin -> usr/bin
 d--x--x--x 2 staff 512 Sep 24 2000 dev
 d--x--x--x 3 staff 512 Sep 25 2000 etc
 dr-xr-xr-x 3 staff 512 Oct 3 2000 pub
 d--x--x--x 5 staff 512 Oct 3 2000 usr
 226 Transfer complete.

I think ftputil should automagically parse this format too,

regards Nicola

Change History (3)

comment:1 Changed 10 years ago by schwa

Description: modified (diff)
Keywords: parser Unix added

I don't seem to be able to reproduce that bug, at least not with ftputil version 2.4:

>>> h = ftputil.FTPHost("ftp.sunfreeware.com", "anonymous", "sschwarzer@sschwarzer.net")
>>> >>> h.listdir(".")
['bin', 'dev', 'etc', 'pub', 'usr']

Which version of ftputil did you use?

comment:2 Changed 10 years ago by schwa

Resolution: invalid
Status: newclosed

As the reporter wrote me he had modified ftputil for an experiment and because of this got a traceback.

Therefore, I close the bug as "invalid".

comment:3 Changed 10 years ago by schwa

Milestone: never
Note: See TracTickets for help on using tickets.