Opened 13 years ago

Closed 4 years ago

#14 closed enhancement (duplicate)

Support for the REST verb.

Reported by: john@… Owned by: schwa
Priority: minor Milestone: 3.3
Component: Library Version: 2.0.3
Keywords: specification, rest Cc:

Description (last modified by schwa)

It would be great if ftputil supported the transfer restarts (i.e. to continue an incomplete download).

From spec (http://war.jgaa.com/ftp/rfc/rfc959.txt):

RESTART (REST)

The argument field represents the server marker at which file transfer is to be restarted. This command does not cause file transfer but skips over the file to the specified data checkpoint. This command shall be immediately followed by the appropriate FTP service command which shall cause file transfer to resume.

Change History (3)

comment:1 Changed 13 years ago by schwa

Milestone: 2.2
Priority: majorminor
Status: newassigned
Version: 2.0.3

comment:2 Changed 4 years ago by schwa

Description: modified (diff)
Keywords: rest added
Milestone: 3.3
Version: 2.0.3

Most likely I won't support the REST verb directly, but rather provide something like in ticket #61.

comment:3 Changed 4 years ago by schwa

Resolution: duplicate
Status: assignedclosed

I'm marking this as duplicate of ticket #61. Subsequent comments will go there.

Note: See TracTickets for help on using tickets.