Opened 17 months ago

Closed 14 months ago

Last modified 14 months ago

#111 closed enhancement (fixed)

Add deprecation warnings on dropping Python 2 support

Reported by: schwa Owned by: schwa
Priority: major Milestone: 3.4
Component: Library Version: 3.3.1
Keywords: deprecation warnings python 2 python 3 Cc:

Description

As explained on the mailing list, a future version 4.0 of ftputil will drop support for Python 2.

For the upcoming version 3.4, add deprecation warnings to notify users about the future lack of Python 2 support.

The only direct public interfaces of ftputil are in ftputil.host and ftputil.error, so add a warning on the module level for these modules.

Change History (2)

comment:1 Changed 17 months ago by schwa

  • Status changed from new to assigned

comment:2 Changed 14 months ago by schwa

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [c48d3e1a3e8a].

This change issues a deprecation warning under Python 2 as soon as ftputil is imported. This also applies to ftputil.error to catch ftputil exceptions, even when not using ftputil.FTPHost.

Last edited 14 months ago by schwa (previous) (diff)
Note: See TracTickets for help on using tickets.