Changeset 860:bf6c26a5a1fe


Ignore:
Timestamp:
Apr 12, 2010, 9:51:07 PM (11 years ago)
Author:
Stefan Schwarzer <sschwarzer@…>
Branch:
default
Message:
Run tests specific for Python 2.4 only if the interpreter is there.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • Makefile

    r816 r860  
    1 # Copyright (C) 2003-2008, Stefan Schwarzer
     1# Copyright (C) 2003-2010, Stefan Schwarzer
    22# All rights reserved.
    33#
     
    3030# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    3131
    32 # $Id$
    33 
    34 
    3532SHELL=/bin/sh
    3633PROJECT_DIR=/home/schwa/sd/python/ftputil
     
    4239WWW_DIR=${HOME}/www
    4340SED=sed -i'' -r -e
     41#TODO some platforms call that script rst2html.py - allow both
    4442RST2HTML=rst2html
    4543PRODUCTION_FILES=ftp_error.py ftp_file.py ftp_path.py ftp_stat_cache.py \
     
    5654
    5755test:
    58         @echo "Tests for ftputil ${VERSION}\n"
    59         python2.4 _test_python2_4.py
     56        @echo "=== Running tests for ftputil ${VERSION} ===\n"
     57        if which python2.4; then \
     58                python2.4 _test_python2_4.py; \
     59        else \
     60                echo "Tests specific for Python 2.4 have been skipped."; \
     61        fi
    6062        for file in $(TEST_FILES); \
    6163        do \
Note: See TracChangeset for help on using the changeset viewer.