Changeset 1688:93401904f9bc


Ignore:
Timestamp:
Oct 29, 2017, 12:35:10 AM (14 months ago)
Author:
Stefan Schwarzer <sschwarzer@…>
Branch:
default
Message:
Add deprecation warning about `use_list_a_option`

Tell other developers that the default of `use_list_a_option` will
change in future ftputil versions. As this is a backward-incompatible
change, it can only be changed in a new major version, i. e. ftputil
4.0.0.

See ticket #110 for the reason of the change.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • ftputil/host.py

    r1677 r1688  
    1717import sys
    1818import time
     19import warnings
    1920
    2021import ftputil.error
     
    9596        # Use `LIST -a` option by default. If this causes problems,
    9697        # the user can set the attribute to `False`.
     98        warnings.warn(
     99          "`use_list_a_option` will default to `False` in ftputil 4.x.x",
     100          DeprecationWarning, stacklevel=2)
    97101        self.use_list_a_option = True
    98102
Note: See TracChangeset for help on using the changeset viewer.