Changeset 1945:7d2ec0a6382d


Ignore:
Timestamp:
May 31, 2020, 8:06:59 PM (14 months ago)
Author:
Stefan Schwarzer <sschwarzer@…>
Branch:
default
Message:
Fix minimum Python version

In order to support path-like objects, we need at least Python 3.6.

It _may_ be possible to create an ftputil version that just doesn't
support path-like objects on Python 3.5, but otherwise works. However,
I think the effort for this wouldn't be justified (especially since
Python 3.5's end-of-life is as close as September 2020, see
https://devguide.python.org/#status-of-python-branches ).
Location:
doc
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • doc/README.txt

    r1944 r1945  
    2424- Python 2 is no longer supported.
    2525
    26 - The minimal supported Python 3 version is 3.5.
     26- The minimal supported Python 3 version is 3.6.
    2727
    2828- The flag `use_list_a_option` of `FTPHost` instances is now set to
     
    4141  listings" minus "local client time."
    4242
    43 If you need to use Python versions before 3.5, please use the previous
     43If you need to use Python versions before 3.6, please use the previous
    4444stable ftputil version 3.4.
    4545
  • doc/announcements.txt

    r1942 r1945  
    1414- Python 2 is no longer supported.
    1515
    16 - The minimal supported Python 3 version is 3.5.
     16- The minimum supported Python 3 version is 3.6.
    1717
    1818- The flag `use_list_a_option` of `FTPHost` instances is now set to
     
    3131  listings" minus "local client time."
    3232
    33 If you need to use Python versions before 3.5, please use the previous
     33If you need to use Python versions before 3.6, please use the previous
    3434stable ftputil version 3.4.
    3535
Note: See TracChangeset for help on using the changeset viewer.