Ignore:
Timestamp:
Dec 26, 2018, 3:22:08 PM (6 months ago)
Author:
Stefan Schwarzer <sschwarzer@…>
Branch:
default
Message:
Remove `compat.py`

This module was for Python 2/3 compatibility, similar to the `six`
package. Since the next version of ftputil will only support Python 3,
hardcode the types from `compat.py` in the code that used to use the
`compat` module.

There may still be redundant code that isn't needed when running the
tests under Python 3.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • test/test_file.py

    r1718 r1721  
    77import pytest
    88
    9 import ftputil.compat
    109import ftputil.error
    1110
     
    2423class ReadMockSessionWithMoreNewlines(mock_ftplib.MockSession):
    2524
    26     mock_file_content = b"\r\n".join(map(ftputil.compat.bytes_type, range(20)))
     25    mock_file_content = b"\r\n".join(map(bytes, range(20)))
    2726
    2827
Note: See TracChangeset for help on using the changeset viewer.